how to prevent HDMI port to sleep

I currently update tk1 to the latest version of L4T R21.4, and run the Ubuntu into the Kiosk session mode, and it run my application in kiosk mode, but the problem is that Ubuntu will put hdmi of jetson tk1 into sleep until you press keyboard, since I am not logging into the ubuntu.desktop session, any setting in the ubuntu.desktop session will not take effect, do anyone have the same problem here? thank you in advance.

I wonder if this is perhaps part of simple low power mode settings. You might try setting all to performance mode and see if this is related or not:
http://elinux.org/Jetson/Performance

If performance settings don’t solve this, then the issue is probably still with the X server (but not window manager).

Hi, thank you for your answer, I tested the ubuntu desktop session, in the setting, I keep the display live, and it works fine, so I will check the related setting, and try to make it active in kiosk mode also.