How to put an Orin NX into recovery mode from 'recovery shell' on UART (without access to FR button)


After i bricked an installed Orin NX with a failed flashing over USB, i am trying to reflash it without having to dismantle everything.

System is on BSP 35.3.1.

I have access to the micro-USB port needed for flashing, as well as the UART pins, not the FR button (we have asked the hardware team to make it accessible, it is not yet and not sure it will ever be).

For now the Orin NX doesn’t boot nor goes into recovery mode to be reflashed.

I managed over UART to enter Setup → Device Manager → NVIDIA Configuration → L4T Configuration and mark both OS chains as <Unbootable> (We use A/B Rootfs, in Production we reflash individual partitions through mender).

Now it reboots into a recovery shell accessible over UART. This still doesn’t allow it to get flashed.
From this shell i tried reboot forced-recovery and while it reboots nicely it only reboots into the same shell, not into recovery as when this same command is used from a full running system.

Also tried in Setup menu to set Boot Maintenance Manager → Boot Next Value to <NONE> with the same result, i only get into the UART shell.

I wonder if from either the Setup or the recovery shell it is possible to force it into recovery mode ?

For now i can dismantle the system to access the Force Recovery button, for the future it would make life easier if this would be possible over UART.

Thanks and best regards,


Most likely not. This would be much too late in the start process. The first core that is running after powerup or reset ist the BPMP, the Boot and Power Management Processor. This is an extra core that does not run Linux or UEFI, and it initializes DRAM and other cores and starts the Linux cores. My guess is that the decision whether to switch into recovery mode or normal mode is done even before the main cores even start up.

So, no, you need extra wires for both reset and recovery mode.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.