How to quit nvgstcapture in full screen mode

When I ran OpenGl applications in full screen mode, I could hit ESC or “Q” or “q” to quit.

I could not figure out how to quit “nvgstcapture” in full screen mode.

I tried to hit “q” everywhere on screen but could not quit “nvgstcapture”.

Does anyone know how to quit “nvgstcapture” in full screen mode?

Thanks in advance.

hi yahoo2016,

may i know which BSP version you were testing?
please also share full input commands you were used.

I’m using the latest Jetpack 2.3, i.e., L4T R24.2.1.
I tried both Nvidia and Leopard CSI-2 cameras, using:

gst-launch-1.0 nvcamerasrc fpsRange=“30.0 30.0” ! ‘video/x-raw(memory:NVMM), width=(int)1920, height=(int)1080, format=(string)I420, framerate=(fraction)30/1’ ! nvtee ! nvvidconv flip-method=2 ! ‘video/x-raw(memory:NVMM), format=(string)I420’ ! nvoverlaysink -e

from this post:

hi yahoo2016,

for the gst-launch-1.0. you should use ctrl^c to shutdown the pipeline, it will send EOS signal since you had set “-e” option.
BTW, nvgstcapture-1.0 is support ‘q’ command to shutdown/terminate the streaming.

I believe I tried ctl-c, ctl-x and ctl-z for “gst-lauch”, I’ll try them again.

When I used “nvgtscapture-1.0” for Leopart IMX274 camera, I got only 640x480 display which is not full screen on 4K monitor.

“nvgtscapture-1.0 --help” showed 9 different resolutions, but when I tried “nvgtscapture-1.0 --video-res=x” (x=6,7,8, or 9), display stayed at 640x480 resolution.

I could not figure out how to change resolution and verify full screen mode using “nvgtscapture-1.0”. Leopart support suggested using “nvgtscapture-1.0 m 1 -video-res=x”, but it did not change video res.


I figured out I should use “nvgtscapture-1.0 --prev-res=x” to set live display resolution.

“q” did work for “nvgtscapture-1.0”