How to Record Physical Simulations

I want to save physical simulations using omniPVD, but I’m unable to do so.
The checkbox becomes grayed out. The documentation states, “If the USD Stage is an OmniPVD Stage (it has OmniPVD prims), the checkbox ‘Recording Enabled’ is grayed out, as it’s not possible to record any simulation data from an OmniPVD Prim, as it remains an animation.” However, I’m not sure how to proceed. Can you please provide some guidance?

Hi there,

Thanks first of all for using OmniPVD. The “Recording Enabled” button is grayed out in two cases

  1. A simulation is already running. You must first stop the simulation, then you can start the recording.
  2. The Stage that you have loaded is an OmniPVD stage recording itself, meaning it has no simulation information. You need to first load a Stage that contain no OmniPVD prim structure and then you can start recording.

Would you mind sharing a screenshot of the Stage View in Kit so that I can see which Prims are in the Stage?

Thank you for getting in touch. I have attached a screenshot below.


Please let me know if you need any more information.

Hi again,

I have attached two screens that show how it works fine to set the recording - not greyed out and to record - without any crashes.

You sent me another screen also of how you were able to record where it was not greyed out - I attached your screen to the bottom, would you mind making sure that the directory that the directory it tries to record into does exist and has writing permissions?

Also would you mind upgrading your IsaacSim version to a version from 2024 or is that the only you have available?

Thank you for your response.
When I start the simulation with options that are not grayed out, the app itself crashes. Is this normal behavior?
Also, I do not understand why it was not grayed out in this instance.

The latest version available in the Omniverse launcher is 23.1.1.
Is there another way to obtain version 2024?

By crashing, does this happen when you press the Play button?

Does the full export directory path exist on your hard drive and do you have write permissions into the final directory of that path (this could have been an issue in older versions)?

What do you mean by not grayed out in this instance? Was it not grayed out before you pressed Play and then became grayed out OR was it not grayed before you pressed Play and then was still not grayed out during?

Does your stage crash with or without OVD recording enabled?

Since you have a crash would you be able to send me a crash dump?

On top of the issue of not having the output directory created, there could a problem of how the IsaacSim Stage has acquired the OmniPhysics interface internal PhysX objects, which will be invalidated if OVD recording is enabled after the Stage is opened because enabling OVD recording (rather switching from a recording to a non-recording state and vice versa) triggers a re-initialization of the internal PhysX DLL interface.

In this case, try the following: before loading any Stage in IsaacSim, first set the output directory and then enable OVD recording. Then you can load the IsaacSim Stage you are interested in and “Play” it.

This is related to the TensorAPI.