How to remove empty line in UEFI logs

I rebuild UEFI firmware to remove logs in other serial port. But in console port there is still many empty line in uefi logs. I compare release_bin and debug_bin, i found that there is a empty line after every load of driver or library. how to remove this?
[com COM3] (2023-02-07_171053) Serial (COM).log (105.5 KB)

Hi livefd03,

These empty lines are the logs disabled for release binary.
If you want to see the debug messages in UEFI, please replace the <Linux_for_Tegra>/bootloader/uefi_jetson.bin with uefi_Jetson_DEBUG.bin which you built.

I tried the release bin. This is the log.
[com COM3] (2023-02-08_173426) Serial (COM).log (23.8 KB)

the official UEFI bin also has this problem on my self-made base board.

The serial console logs looks as expected.

Do you have any purpose to remove all of them?

I just want to remove these empty lines.

Sorry, these empty lines could not be removed.
The UEFI is doing some stuffs at this moment.

I checked the source code and found that a newline is printed when the serial port is initialized, but I don’t understand why the serial port is initialized every time the driver or library is loaded. I removed the newline there for serial port initialization and solved this problem. In addition, there is also a clear screen action in those newline, which I also deleted, and now the UEFI stage serial port looks normal.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.