How to reserve cpu core's on nvidia jetson xavier agx?


Yes we can re-flash. But we have flashed our custom Image recently into the target and before that also the system behaviour was same.

So can you tell me what would change if we reflash??

On default Xaviier/r32.6.1, we can add isolcpus in extlinux.conf, and see it in /proc/cmdline after rebooting the system. It is uncertain why it does not work in your setup although you have confirmed there is only one extlinux.conf file in your rootfs. So if you use the default image, it should work after re-flashing the system.

Do you use Xavier developer kit or your custom board?


we are not using the default Image in our setup , we have build a custom Image. And also we don’t have default xavier developer kit , it has some customizations in it.

So it won’t be possible to flash default Image in this board.

Below is my extlinux.conf file and cat /proc/cmdline outputs:

Please let me know , If we can debug the issue without flash because at the end it is a nvidia jetson only so it should have similar functionality.

Please check if this post helps:
How to redefine TX2NX dtb - #2 by linuxdev

Probably this makes the setting in extlinux.conf be ignored:

Do note that if the .dtb file is not found from the FDT entry, then it will revert to using the one in a partition instead.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.