How to run MPI through the ND mode

Hello,

We can’t run MPI through the ND mode, only the Socket mode runs successfully.

Our environment is Win10 1709, Mellanox Connect-X 3, WinOF v5.5. Another Computer is Mellanox Connect-X 2.The instruction is:

mpiexec.exe -hosts 2 11.4.12.10 11.4.12.12 -env MPICH_NETMASK 11.4.12.10/255.255.255.0 -env MSMPI_ND_ZCOPY_THRESHOLD -1 -env MSMPI_DISABLE_ND 0 -env MSMPI_DISABLE_SOCK 1 -affinity “$(TargetPath)”

But the result is:

job aborted:

[ranks] message

[0] fatal error

Fatal error in MPI_Send: Other MPI error, error stack:

MPI_Send(buf=0x00000297A8661070, count=419430400, MPI_CHAR, dest=1, tag=4, MPI_COMM_WORLD) failed

unable to connect to 192.168.18.5 11.4.12.12 DESKTOP-U5E19NF on port 0, the socket interconnect is disabled

[1] terminated

---- error analysis -----

[0] on 11.4.12.10

mpi has detected a fatal error and aborted C:\Users\MPITest\Desktop\MSMPI\x64\Debug\MSMPI.exe

---- error analysis -----

We can’t find the reason, Can you give us any advices?Thanks for your time.

Through the help of some kind-hearted people, I solved this problem. That’s because I did not install the ND driver.(Execute “ndinstall -i” command with administrative access)

Now it runs successfully, Very grateful.