How to run Ubuntu 22.04 on the Jetson Nano

Sorry I’m not sure where to add on the jetson as I’m more familiar with using grub.

# nano /boot/extlinux/extlinux.conf

on the last line of the LABEL primary

1 Like

I’ve upgraded CUDA 10 to 11. Now the Jetson Nano software has been well refreshed. The last thing that I want to try is to upgrade the kernel. It is still 4.9. Too old. I would like to try 5.x ; someone has some good articles that suggest to me how to do that ? I will do the rest. thanks.

4 Likes

Incredible! Love to get that installed as well. Do you have a guide or some notes to share?

I think my GPU is disabled currently so will likely have to get that working again.

The Armbian team has a newer kernel in their build for the nano (6.1.x.) I have not tried as of yet. I did not get a response when I asked on the status of the image.

1 Like

I think that using new kernel will not enable the gpu to work with a new version of cuda. I dont even need of it. On my nano.everything works great if I use CUDA 10.

I think you are correct. If it boots at all it likely just runs as a basic A57 SBC with minimal GPU. I don’t know how the “desktop” build works.

I think without something supportable with the firmware I doubt we can update the kernel.

we are talking about different components. maybe. anyway my idea is to use the kernel of the orin and the FDT tree of the jetson. Probably the kernel 5 config file used on the nano needs to be reconfigured. But the correct config is inside the config. file of the 4.9. so we should extract all the relevant informations from there and import them on the 5 :)

Xorg 1.21 doesn’t work with nvidia libs 32.x l4t package you are running mesa3d driver running not nvgpu driver.
You needed down to 1.20 for full 3d gpu working i.e opengl 4.6 and vulkan and cuda working .

About what CUDA version are you talking about ? 10 or 11 ? If you are talking about CUDA 10,my next experiment would be to hold the working xorg package with the command

sudo apt-mark hold <package-name>

to try to use the Xorg which works on ubuntu 18.04 on the 22.04. Anyway,unfortunately I can’t make further experiments with my jetson nano. Actually it is broken and I’m not able to fix it. The problem is that I tried to boot ubuntu using the sd card to usb converter. After some time something broke. I think that it’s not my fault. Booting Ubuntu using the USB mechanism is weak. But I’ve been forced to use that method,since the sd card slot of my board is defective. I’m not sure that the nvidia developers made a good job programming the “booting from USB” feature. It shouldn’t have broken. This is the error that persists :

Bus usb@7d000000: tegrausb: Invalid dr_mode 2 for host mode                               
probe failed, error -1

As suggested,actually I’m trying to put the board in recovery mode,but it is not detected by ubuntu. You can give a look here :

and here :

https://www.reddit.com/r/JetsonNano/comments/13gt9vx/recovery_mode_does_not_work_on_my_jetson_nano/

I’m not able to put it in recovery mode. I’m frustrated.

I mean holding sudo apt hold xorg-* or reverting the changes I’ve said in the link related to xserver
This is how I have it working for now with cuda10.
The next thing is to try cuda 11 or cuda12 to see if there is a limitation here.

Exactly. My jetson nano broke a moment before to try the installation of CUDA 11 on ubuntu 18.04 as suggested by the seeeed studio small tutorial.

Seems are install with CUDA Toolkit - Free Tools and Training | NVIDIA Developer but bad news for cuda 12.1
cuda drivers are insufficient driver for run cuda 12
It is probably because it requires more current base drivers for supported.

so,CUDA 11 would work,but 12 not ? well,better than nothing. What do you mean with :

It is probably because it requires more current base drivers for supported.

elaborate more.

Throws a specific error for insufficient cuda drivers
cuda runtime error (35)
Similar issue checked for orin in the past.

ok. my idea is the following one : try to get the file called libcuda.so.1.1 from the orin jetpack and use it on the jetson nano. That’s because the nvidia developers said that there is a bug they fixed. The fix is not for the jetson nano,but for the jetson orin. So,our hope is that it works also for the jetson nano. I will try this for sure when I have fixed my broken board.

1 Like

Where should I download the iso image for Ubuntu 22.04 that is suitable for my Jetson Nano ?

3 Likes

I’m using Jetson Tx1 and try the following guide to successfully upgrade to version 20.04
Install Ubuntu 20.04 on Jetson Nano - Q-engineering.
But when I do the same to upgrade to version 22.04, it just simply broken.
How can you guy update your nano to 22.04 ?

It is true. Jetson nano is popular cause its price. But nvidia just support them with Ubuntu 18.04. As everyone known, ros2 lts(humble) version need ubuntu 22.04. When you get an jetson nano to try develop robot, it will be a huge challenge.
This means you have to build an ubuntu 22.04 for it or build ros2 for ubuntu18.04.