How to run Unigine Sanctuary 2.3 ?

I downloaded the Unigine Sanctuary demo 2.3 for Linux. Apparently, I get a binary file, the checksum matches with that on the download site, fine.

I tried to run it with sh, as the other demos are run:

% sh Unigine_Sanctuary-2.3.run
Unigine_Sanctuary-2.3.run: 1: Unigine_Sanctuary-2.3.run: ???: not found
Unigine_Sanctuary-2.3.run: 2: Unigine_Sanctuary-2.3.run: : not found
Unigine_Sanctuary-2.3.run: 3: Unigine_Sanctuary-2.3.run: Syntax error: word unexpected (expecting “)”)

% file Unigine_Sanctuary-2.3.run
Unigine_Sanctuary-2.3.run: Composite Document File V2 Document, Little Endian, Os: Windows, Version 6.1, Code page: 1252, Title: Installation Database, Subject: Unigine Sanctuary Demo v2.3, Author: Unigine Corp., Keywords: Installer, Comments: This installer database contains the logic and data required to install Unigine Sanctuary Demo v2.3., Template: Intel;1033, Revision Number: {3D4F7475-D4A0-4E12-A1B6-DA281A37FFAD}, Create Time/Date: Fri May 21 07:07:32 2010, Last Saved Time/Date: Fri May 21 07:07:32 2010, Number of Pages: 100, Number of Words: 2, Name of Creating Application: Windows Installer XML (3.0.4318.0), Security: 2

How on earth can I unpack this file ? I tried to download the cdf tools from NASA but the don’t recognize the file version.

This looks not like the linux version of the installer.

Right. But this is linked on the download page:

http://download.chip.eu/en/Unigine-Sanctuary-Benchmark-Linux_8061020.html

Does anyone have the really Linux version at hand ?


This is the linux-version, but if you extract it, then the console is looking like that:

towo@Druck-Buero:~/privat$ sh Unigine_Sanctuary-2.3.run
Creating directory sanctuary
Verifying archive integrity... All good.
Uncompressing Unigine Sanctuary Demo v2.2...........
Unigine Sanctuary Demo v2.2

I wrote to the Unigine support and they responded quickly. The right link is:

https://www.dropbox.com/s/9ps37eb0cifs904/Unigine_Sanctuary-2.3.run

Indeed, the installer prints 2.2 but Settings/Credits says 2.3.