How to set communication type in cgf helloworld node?

I found the helloworld sample use default share memory to communicate between nodes, but I want to use socket , how to make configuration to make nodes transport data in socket whether in one process or multiple process? If there are any references, please point them out. Thank you!

Please provide the following info (tick the boxes after creating this topic):
Software Version
DRIVE OS 6.0.6
DRIVE OS 6.0.5
DRIVE OS 6.0.4 (rev. 1)
DRIVE OS 6.0.4 SDK
other

Target Operating System
Linux
QNX
other

Hardware Platform
DRIVE AGX Orin Developer Kit (940-63710-0010-300)
DRIVE AGX Orin Developer Kit (940-63710-0010-200)
DRIVE AGX Orin Developer Kit (940-63710-0010-100)
DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
DRIVE AGX Orin Developer Kit (not sure its number)
other

SDK Manager Version
1.9.3.10904
other

Host Machine Version
native Ubuntu Linux 20.04 Host installed with SDK Manager
native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers
other

Dear @wuyingjin,
My apologies for missing this topic. Could you point me to sample you are referring.

Hi,@ SivaRamaKrishnaNV
I refer to this HelloWorldNode sample.


And I want to add custom structures and set custom communication type, so I make some modifications like this picture below.
Can you give some references to help ? Thanks!

This is my modification, how can I set a custom communication configuration? Thanks!

Dear @wuyingjin,
Please check CGFDemo.app.json. Under connections, params Key can have an entry type : socket/nvsci. . This is used to set communication type.

Hi, @SivaRamaKrishnaNV , I add the params Key type like this, but it fails to check. Please give a more specific example, thanks.

Hi, @SivaRamaKrishnaNV , I found a runtime error after setting nvsci in app.json. Have you ever tested and fully validated it? Please have a look.

This is the screenshot with the last question.

Dear @wuyingjin,
Is the sample working with other type value? Let me check on nvsci and get back to you. Could you attach the JSON file for repro the issue?

Hi, @SivaRamaKrishnaNV
Yes, it works when setting the type value socket.
And I want to know whether there are some configurations missing that cause it.
This is the graphlet JSON file. Please have a look.
team_node.7z (2.9 KB)
image

Hi, @SivaRamaKrishnaNV
This is the corresponding configuration in /etc/nvsciipc.cfg with the last question.


This is the runtime log. Please have a look and give a quick response and useful solutions. It is really important for our project. Thanks!
team_node_log.tar (10.5 KB)

We found that the syslog prints nvsci error. Is there something wrong that causes it?

Dear @wuyingjin,
Thanks for sharing the config files. I guess few additional changes are needed in config files to include src/dst endpoints when using nvsci. I am checking with core team on additional changes in configuration when using type:nvsci.

Hi, @SivaRamaKrishnaNV , have you got the result from the core team? I am waiting for your reply. Thanks!

Dear @wuyingji,
I am yet to receive an update. I will chase this issue and update you soon. Thank you for your patience.

@SivaRamaKrishnaNV Friendly ping for any updates.

Hi, @SivaRamaKrishnaNV
Is there any feedback from the team support? We want to know how to configure nvsci channel in cgf properly, such as .app.json and code examples. If there are any references or documents, please offer as soon as possible. Thanks.

close.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.