How to set -maxrregcount ?

Hi All,

I want to set my -maxrregcount is 20 which now takes 40 and gives 0.25 occupancy.

For this I go through
Project->properties->CUDA->command Line

write in the box of Additional options -maxrregcount =20 .

But when I rebuild and execute my project using profiler still get register per thread is 40 .

My question is how to set my -maxrregcount to 20?

When I set option Project->properties->CUDA->Advanced-> maximum register to 20 then i get error

Could any one help?

You may want to mention which IDE you’re using :)


It is either the space between “maxrregcount” and “=”


You should actually specify “–maxregcount”. Another “-” is required, I think.


Thanks Quoc Vinh , Sarnath and Nico , “–maxrregcount=20” gives correct output.