How to set MLNX_ofed 23.07 into ethernet mode?

I don’t have the option to set LINK_TYPE_P1 or P2…

Only VPI HCA can change port type.

Follow below,

Yes, I have Mellanox ConnectX-6 Dx meaning I should have VPI HCA, no?

Device info: ThinkSystem Mellanox ConnectX-6 Dx 100GbE QSFP56 2-port PICe 4 Ethernet Adapter

Running mlxconfig -d /dev/mst/… set LINK_TYPE_P1=2 LINK_TYPE_P2=2

gives ‘The Device doesn’t support LINK_TYPE_P1 parameter’

CX6-DX is ETH HCA ONLY. You can’t change

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.