How to set smp_affinity of irqs

I have set smp_affinity for irqs, but when irqbalance service is enabled, the smp_affinity will be modified.
How to keep the smp_affinity same when irqbalance service is enabled?

Hello Hukeeda,

Thank you for posting your inquiry on the NVIDIA Developer Forum - Infrastructure and Networking - Section.

Your request is more a Linux general question then it is related to one of our products.

For ‘irqbalance’ to ignore you smp_affinity list, you need to use the option ‘–banirq’

From ‘irqbalance’ man-page:

-i, --banirq=
Add the specified IRQ to the set of banned IRQs. irqbalance will not affect the
affinity of any IRQs on the banned list, allowing them to be specified manually.
This option is addative and can be specified multiple times. For example to ban
IRQs 43 and 44 from balancing, use the following command line: irqbalance
–banirq=43 --banirq=44

Hope this helps.

Thank you and regards,
~NVIDIA Networking Technical Support

Thank you !

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.