How to setup i2s on orinnx?

image
Hwo to setup this I2S on orinnx? I don’t know call it I2S1 or I2S4?

I know I can setup the same port on tx2nx with the following command and need not redefine the device tree.

busybox devmem 0x0c302010 32 0x00000051
busybox devmem 0x02431020 32 0x00000408
busybox devmem 0x02431028 32 0x00000440
busybox devmem 0x02431030 32 0x00000450
busybox devmem 0x02431038 32 0x00000400
busybox devmem 0x02431040 32 0x00000440
amixer -c tegrasndt186ref cset name="I2S3 Mux" "ADMAIF1"
amixer -c tegrasndt186ref cset name="ADMAIF1 Mux" "I2S3"

JP5.1.1
I can see the sclk and fs have signal but din and aud_mclk not work.
I can not find any about the aud_mclk in the orin trm

if i busybox devmem 0x02431020
[ 683.078370] CPU:0, Error: cbb-fabric@0x13a00000, irq=25
[ 683.083792] **************************************
[ 683.088728] CPU:0, Error:cbb-fabric, Errmon:2
[ 683.093215] Error Code : DECODE_ERR
[ 683.097168]
[ 683.098703] Error Code : DECODE_ERR
[ 683.102650] MASTER_ID : CCPLEX
[ 683.106149] Address : 0x2431030
[ 683.109742] Cache : 0x0 – Device Non-Bufferable
[ 683.114951] Protection : 0x2 – Unprivileged, Non-Secure, Data Access
[ 683.121934] Access_Type : Write
[ 683.125523] Access_ID : 0xb
[ 683.125526] Fabric : cbb-fabric
[ 683.132335] Slave_Id : 0x2e
[ 683.135559] Burst_length : 0x0
[ 683.139053] Burst_type : 0x1
[ 683.142370] Beat_size : 0x2
[ 683.145596] VQC : 0x0
[ 683.148381] GRPSEC : 0x7e
[ 683.151434] FALCONSEC : 0x0
[ 683.154667] **************************************
[ 683.159742] WARNING: CPU: 0 PID: 0 at drivers/soc/tegra/cbb/tegra234-cbb.c:577 tegra234_cbb_isr+0x130/0x170
[ 683.170184] —[ end trace 2ca80dc772e0241d ]—

Hi,
Please share your use-case. If you are enabling a audio codec, we suggest modify device tree to enable the interface.

My use-case is very simple, just connect es8388 to aplay.
Must I modify the device tree? Because I use this codec on tx2nx without modify the device tree.

Hi,
The standard method is to modify device tree for enabling the codec. There is audio codec RT5640 in Orin developer kit. Please refer to device tree in

hardware/nvidia/platform/t23x/concord/kernel-dts/tegra234-p3737-audio-codec-rt5640.dts

Can I resolve it in the user-space like tx2nx?
image
On this picture, I use I2S1 or I2S4?

Hi,
Please follow developer guide to enable audio codec:
Audio Setup and Development — Jetson Linux Developer Guide documentation

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.