How to setup jetson-tk1 to actually be usable?

The number of programs I’d like to install won’t fit on the hard drive of the jetson-tk1. I have a USB external hard drive. I tried installing the system on the hard drive and it’s very broken. I’ll try to reinstall it on the eMMC. How can I make it so that it uses the USB drive as my home folder and installs new programs there?

Just mount the external drive to /home. Type “man mount” into a command line to read more about that.

Note that this is not related to the Jetson at all, that’s a generic Linux issue.

Yes, sorry for the newbie question. Would I need to mount /usr to the external hard drive so that all of the programs I install get saved there? My problem is the programs themselves take up more room than is available on the hard drive.

Depends on where the programs are installed. Usually, stuff you install yourself is copied to /usr/local to not interfere with the system stuff. This is where you should mount.

If you’re mounting /usr to an external drive, keep in mind that you have to copy everything there to your disk first, otherwise you’ll break your system, because many regular command line tools are in /usr/bin and /usr/sbin.

I took one of these 64 GByte SDHC/SDXC (UHS 1) cards which have a good price/performance ratio.
From the specification it looks like you don’t need to buy SD cards better than UHS 1,
because they won’t support higher speed in the Jetson TK1.

-formatted SD card to ext4
-tared my rootfs on the Jetson
#cd /
#tar czvf rfs.tar.gz /
-mounted the SD card
#mkdir -p /media/sdmount
#mount -t ext4 /dev/mmcblk1p1 /media/sdmount
-copied tar archive to the SDXC card
#cp /rfs.tar.gz /media/sdmount
-untared rootfs on the SDXC card
#cd /media/sdmount
#tar xvf rfs.tar.gz
-reflashed Jetson Tk1 from x86 host PC with Ubuntu 12.04
(reflashing can only be done from x86 PC) with:
#./ -k 6 jetson-tk1 mmcblk1p1
to boot from SD card.

Now my SD card layout looks like this:
ubuntu@tegra-ubuntu:~$ df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/root        59G  4.2G   52G   8% /
devtmpfs        850M  4.0K  850M   1% /dev
none            4.0K     0  4.0K   0% /sys/fs/cgroup
none            175M  760K  174M   1% /run
none            5.0M     0  5.0M   0% /run/lock
none            874M   60M  814M   7% /run/shm
none            100M   52K  100M   1% /run/user

This didn’t work for me for a few reasons.

  1. Are you logged into the Jetson-TK1 board while you are doing this, or on another linux machine?

When I tried to tar / it had an error about how it couldn’t compress / because it was changing. In other words, it was trying to compress its self and it didn’t like that.

  1. There is no in /

  2. I tried downloading the two packages (the sample root filesystem and Tegra124_Linux_R21.2.0 …)

I tried building the system like it says in the quick-start guide, and then flashing to the SD card, but it wouldn’t work. I would get this error:

./ line 927: ./mkgpt: cannot execute binary file: Exec format error

x86 only binary. Not meant to run from Jetson. Was your host you were flashing from a standard linux desktop machine?