How to slow down Quadro 4000

I have a Quadro 4000.

I just use it to display graphics. I do not want to do use it’s capabilities, other than being able to display Ubuntu on my screen. It just came with a PC that I use.

It idles at around 90C. Here is the output from nvidia-smi

| NVIDIA-SMI 375.26                 Driver Version: 375.26                    |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|   0  Quadro 4000         Off  | 0000:03:00.0      On |                  N/A |
| 61%   87C    P0    N/A /  N/A |    522MiB /  1984MiB |      1%      Default |
| Processes:                                                       GPU Memory |
|  GPU       PID  Type  Process name                               Usage      |
|    0      1577    G   /usr/lib/xorg/Xorg                             304MiB |
|    0      2764    G   /usr/bin/gnome-shell                           216MiB |

I believe the problem is because the heatsink is clogged. Before I attempt to unclog it, I just want to try to throttle it to slow down, and therefore cool down.

I have tried:

$ nvidia-settings -a [gpu:0]/GPUPowerMizerMode=0

Which returns:

Attribute ‘GPUPowerMizerMode’ (T7500:0[gpu:0]) assigned value 0.

However, that does not seem to have an effect in NVIDAI X Server settings.

I suspect this could be because the automatic throtting keeps changing the performane level again. But I am not sure.

What else could I try?

I took off the plate on top of the card, and then blew off the dust. It’s now idling at 87C, so not significantly better. But the fan has become a lot quieter.