How to start "make xconfig" with search ability?

Tried JetsonHacks’ script to compile kernel and drivers on TX2 without going thru a host. At the very end the script pops up a Kernel Configuration window. When I tried to re-open the configuration GUI using the command blow:

$ cd /usr/src/kernel/kernel-4.4/
make xconfig

I got a GUI looked slightly different from what JetsonHacks’ script would produce. I can’t get the “file, edit, etc” menu on the frame. I can’t search the configuration.

I also tried to run nconfig in the same directory

make nconfig

But the system prompted a fatal error

scripts/kconfig/nconf.h:18:20: fatal error: curses.h: No such file or directory

Any idea on how to fix that?

When I did this on a host PC the menu was not attached to the window, but in the far upper-left hand corner of the screen.

However, when I did the same thing directly on the TX2 the menu was attached the the GUI window.

I remember it being a bit misleading. Perhaps the menu just isn’t where you’re looking?

The different utilities of a kernel build such as text mode “make menuconfig” or “make nconfig” require installing package libncurses5-dev (the make target links against this command line drawing utility):

sudo apt-get install libncurses5-dev

“make xconfig” uses some GUI widgets, so it doesn’t care about ncurses…this instead wants:

sudo apt-get install qt4-dev-tools

@Deenz, thank you for pointing out that the menu is in the far upper-left hand corner of the screen.
Aha! it’s indeed in the “far” corner of the “monitor screen”. Earlier I was looking at the GUI inside of Kernel Configuration window, so I missed it.

If you looked at the YouTube tutorial of “Build Kernel and Modules - NVIDIA Jetson TX2” around time stamp 3:00 minute
[url]https://www.youtube.com/watch?v=fxWObd1nK4s[/url
you’d see the menu is under the header of “Linux/arm64 4.4.15 Kernel Configuration”. If you move the window, the menu moves with it. I got the same result when I ran the script on TX2.

Now if I restart the configuration, the GUI menu goes to a slightly difference place. It’s on the top bar of the screen. If you drag the Kernel Configuration window, the window moves but the menu won’t go with it. By the way, the GUI header shows “Linux/arm64 4.4.38 Kernel Configuration” on my TX2. (Notice the difference in version)

@linxdev, I see your point. I can’t run “make nconfig” without installing libncurses5-dev.

“make xconfig” is good for now. So, I’d say the problem is solved. Again, thanks for all the responses.

There is one small detail that’s worth bringing up.

When you open the GUI of Kernel Configuration, you actually won’t be able to see the menu on the top-bar until you have your “mouse-over” the top-bar. You would only see a duplicate of GUI title when mouse-out.