How to turn off face detection in PeopleNet/tracking/nvdsanalytics

Hello, this is a quick question. How do I turn off certain class outputs from models? I am using peoplenet to count people, yet it counts their faces aswell

You can try to delete other class in the label file.

Doesn’t work, just outputs null as the object name

It is a topic for deepstream. Please try to use operate-on-class-ids which is mentioned in Gst-nvinferserver — DeepStream 6.1.1 Release documentation . If still not work, please create a new topic in deepstream forum for help.

1 Like

Although setting operate-on-class-ids didn’t change anything, I managed to solve the problem by specifying class-id in the nvdsanalytics component, thank you @Morganh

1 Like

I think a better option is to add this to your PGIE’s configuration:

[class-attrs-2]
# disable detection by setting it above 1.0
pre-cluster-threshold=1.1

More about it is here.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.