How to undo memory swap

I’m new to the Jetson platform and I was just following Getting Started with AI on the Jetson Nano course. When I got to the part with the JupyterNoteBook everything was running fine until I reached the Display the Interactive Tool portion. There when I wanted to add an image it kept saying:

OSError: [Errno 12] Cannot allocate memory

So I followed this video on Jetsonhacks.com* to do a memory swap. After I did what he said in the video and I ran the code. the very first line isn’t working either. It was working fine before. Does anyone have a solution for this? Should I just undo the memory swap? If so how would I do it?
Any help would be greatly appreciated!

*Jetson Nano – Even More Swap – JetsonHacks.

Maybe need to check what those script done and revert it or just reflash the system.

How would I revert it? This is what I ran:

$ git clone h ttps://github.com/JetsonHacksNano/resizeSwapMemory

$ cd resizeSwapMemory

$ ./setSwapMemorySize.sh -g 4

These lines changed the entire swap memory size to 4GB. (Btw I added a space behind the h in HTTPS because it kept turning the line into a URL.

You need to know setSwapMemorySize.sh and check if can revert it or not.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.