How to update cuda on TX2 without re-flashing TX2

Hello guys,

we have compiled a Qt application on TX2 requires cuda 9.0.
Now we want to upgrade the cuda to 10.0 on TX2 without re-flashing the whole TX2 since we don’t want to re setup the development environment for the application.

anyway to do this?
using the SDK manager on host linux PC will flash TX2 completely, right?

Hi vic420, re-flashing the device is currently required to update CUDA toolkit version, as it also depends on the L4T BSP version that contains the correct drivers and kernel. It’s recommended to backup any files and configuration you wish to save before flashing the latest JetPack with SDK Manager, as the filesystem of your Jetson will be reset.

In the future we plan to move to OTA updates through an apt package manager server, so you won’t need to re-flash your device to upgrade.

Thanks for your info. I will try out.

Thanks, is OTA update ready now?

any other way to update the CUDA manually? via SDK manager on host Linux machine to update the cuda on TX2 always reports errors and I have no idea where to start.

Yes, the new APT package update server is part of JetPack 4.3. You will still need to re-flash your device to get onto JetPack 4.3 from a previous version of JetPack, but once you are on 4.3 you will be able to upgrade to future releases by way of “sudo apt upgrade” (see here for more info)

To upgrade to JetPack 4.3, the entire device needs re-flashed with SDK Manager. It isn’t possible just to upgrade CUDA version.

If you are having problems with SDK Manager, you could flash the OS with the L4T BSP tools. Then manually copy the other packages that SDK Manager downloads (e.g. CUDA toolkit, cuDNN, TensorRT, ect) to your board and install them there by hand. Or once you have installed the JetPack 4.3 OS with the L4T BSP tools, you may be able to use the APT server to install the other packages (haven’t personally tried that method before)

Thanks very much for your help. I will try it.

Is there something wrong with the repo servers?

When I am running :

sudo apt update

I get this information:
Err:20 r32/main arm64 Packages
File has unexpected size (8084 != 7930). Mirror sync in progress? [IP: 443]
Hashes of expected file:

  • Filesize:7930 [weak]
  • SHA256:a80383566cab2ea7baa68c7c17ac6f581b7ec47d376d832c1824d2fd1ab8916e
  • SHA1:268b9c78b441a358f804dab1b1c67c7c91ffbad7 [weak]
  • MD5Sum:6d1e8cb93e0f23410eecfd8007d2e4df [weak]
    Release file created at: Tue, 17 Dec 2019 23:52:06 +0000
    Fetched 270 kB in 4s (66.1 kB/s)

Hi renrui,

Have you tried it again? If still an issue, please open a new topic. Thanks