How to upgrade tensorrt

I want to upgrade tensorrt to 8.6.1 such that it supports bool instead of np.bool because np.bool was deprecated. But if I use

pip install tensorrt --upgrade

The error occurs:

ERROR: Could not build wheels for tensorrt, which is required to install pyproject.toml-based projects

If I want to upgrade it via sudo apt upgrade tensorrt, it shows tensorrt is already the newest version (8.5.2.2-1+cuda11.4)..

So how to upgrade tensorrt to 8.6.1 in order to support bool? Besides, I don’t want to use the container.

Environment:
cuda: 11.4
Jetpack: 5.1.3
python: 3.8
Present Tensorrt version: 8.5.2.2
System: Ubuntu 20.04

Hi,

If you are using Orin module, I would like to suggest you to go with jetpack 6.0. Here you can freely install different versions of CUDA, cuDNN and TensorRT too.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.