How to use GPIO07 and microSD in Jetson Tx2 NX

Hi Nvidia:
I Sorry about my English is bad

I have Two problem
Problem One:
We want to set GPIO07 reset to high.
I See GPIO7_TOUCH_RST is GPIO3_PS.03 in Jetson-TX2-Generic-Customer-Pinmux-Template.xlsm.

So. gpio number is 0*8+3+256 = 259,But is no Work,GPIO7 is state_LED, We only want set low or high
I also try GPIO number 256,323, 320 , But it still doesn’t work

There is my step:

echo (256/259/323/320) > /sys/class/gpio/export
cd  /sys/class/gpio/gpio[256/259/323/320]
echo out > direction
echo 1 > value   
echo 0 > value   

Problem two:
We want use microSD in out Project
it doesn’t work
We dowmload Jetson_Linux_R32.7.1_aarch64.tbz2(L4T Driver Package (BSP)) and Tegra_Linux_Sample-Root-Filesystem_R32.7.1_aarch64.tbz2(Sample Root Filesystem) to build and program Jetson TX2 NX
(Download URL Page :
No change anything in code
What should I do next step
Please Help me

  1. For the gpio, try other pins and see if it can work. Especially the pin on the 40 pin headers.

  2. Please search sdmmc3 posts over the forum and it shall tell. Default software does not support extra sdcard slot. It requires device tree change.

21 * 8 + 1 + 320 = 489 (488)
it doesn’t work
I try other pin on same way.
Unfortunately, No work.
This should be such a simple task(/(ㄒoㄒ)/~~)

The problem 1 was solved, which I mixed the wrong excel sheet.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.