How to use Leopard Imaging MIPI Cameras on Jetson TX2

Hello, I have been trying to install the IMX477 camera module from Leopard Imaging on my TX2 (Jetpack R28.2) and I am so far failing. I updated from 28.1 to 28.2 and still, the Leopard camera module does not show up under /dev/. The embedded one, i.e. the one that comes with the development kit, works fine.

The most recent document outlaying how to make it work is from 2016; It refers to configuration that no longer works the same way:

https://developer.download.nvidia.com/embedded/L4T/r24_Release_v2.0/Docs/Tegra_Linux_Driver_Package_Release_Notes_R24.2.pdf?Zi3pxv2iWyLZBhR7B6OA-p87WUrZ-ah-xZz4pEXiAqy3-zk-Zd3Uy-sTN8X1He91ESHD-Vj14eYcYZbATKqXb4Cxlwmivg0na6FI8Ky0O2KODSsICcJpENOYkDgj8G2zosoF8bidbd590Xiq83l3jPMvCxnyxahKi6yT97wvLkBJjwWqwcP_cd7lGDFI9Pr6WwGCuQ

Is there an up-to-date, step by step guide on how to “update the linux device tree” for people who don’t know the inner workings of Linux? It would be immensely helpful for people delving into the embedded space for the first time.

Hi kpashov,

If you are using the LI-JTX1-MIPI-ADPT + IMX477 camera kit, please refer to below guide to install the TX2 driver.

Hi SimonZhu,

Is there an updated version of that guide since the link doesn’t work anymore?

Hi kyle.borg10,

Please try this guide.

https://www.dropbox.com/s/ocv59a6pgt5wco3/IMX477_R28.2_TX2_NV_Tri_20180524.txt?dl=0

Hi SimonZhu,

Thanks for the guide. Would it be a problem if a newer version of L4T is installed? I am currently making use of L4T 32.1 which was installed by JetPack 4.2.

Hi kyle.borg10,
Please contract support@leopardimaging.com for new driver support.