How to use Nvros in DRIVE OS 5.2.6

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
[o] DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System
[o] Linux

Hardware Platform
[o] NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version
[o] 1.9.10816

Host Machine Version
[o] native Ubuntu 18.04

I want to run Nvros on the target pc. Nvros is installed in the /opt/nvidia/nvros path of the target pc.

The problem i’m facing is :

But when I run the nvros command, it says that the command cannot be found. For example, when the roscore command is executed, the roscore of “/opt/ros/melodic” is executed instead of the roscore of “/opt/nvidia/nvros”.

How can I run nvros commands?

Dear @rlfxogud961,
Di you follow the ROS installation steps from " Installing ROS" Section in NVIDIA_DRIVE_OS_5.2_NvROS_Example_Integration_Guide/nvvib_docs/index.html. Please double check if source /opt/ros/melodic/setup.bash and other steps in “Verify Installation” is followed