How to use the command line distribution Wi-Fi in Jetson Nano?

Hi all!

What should I do if I want to open the Wi-Fi to nano with the command line?I have tried using wpa_supplicant configuration, but it failed.The error message is as follows。Or nano does not support configuring Wi-Fi using the command line?

fors1f@fors1f-desktop:~/app$ sudo wpa_passphrase testwifi 12345678 > ./wpa.conf
fors1f@fors1f-desktop:~/app$
fors1f@fors1f-desktop:~/app$ sudo wpa_supplicant -iwlan0 -B -c ./wpa.conf
Successfully initialized wpa_supplicant
nl80211: Could not set interface ‘p2p-dev-wlan0’ UP
nl80211: deinit ifname=p2p-dev-wlan0 disabled_11b_rates=0
p2p-dev-wlan0: Failed to initialize driver interface
P2P: Failed to enable P2P Device interface

Hi all!

I have solved this problem, because there is a NetworkManage folder in the etc directory of nano, so you can use NetworkManager’s nmcli command to configure and operate the network,

Wi-Fi name:Samsung-printer
Password:12345678(the password between Samsung-printer and 12345678 must carry)

for example: nmcli device wifi connect Samsung-printer password 12345678

1 Like