How to use udp protocol when pull rtsp stream

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson)
• DeepStream Version:6.0
• JetPack Version (valid for Jetson only):4.6
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

hi, guy,
I want to use udp when pull rtsp stream, I set select-rtp-protocol equal 0, but it is not useful.

how to set parameters?

What is your RTSP server settings? Is it UDP or TCP? DeepStream source is the RTSP client, you should set the client according to the server.

The server is camera which produced by uniview.
The camera support botch tcp and udp.
The ffmpeg can pull by tcp and udp. but deepstream only support tcp.
I want to pull the stream by udp, what can I do?

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

In create_rtsp_src_bin() function in /opt/deepstream/deepstream/sources/apps/apps-common/src/deepstream_source_bin.c, only “4” or “7” is set to rtspstc " protocols" property. You can modify the code and rebuild the deepstream-app to enable UDP only configuration.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.