HOWTO: Run Jupyter Course directly on the Nano

Hello all, I have two Nano’s from a project I just inherited and am under the gun. To teach myself about Deepstream I am running the “Building Video AI Applications at the Edge on Jetson Nano” course. Was doing fine until it failed to stream RTSP then the Nano failed (long story). Now with the identical 2nd Nano, it does not connect to my laptop (i.e., heedlessly) correctly. It has intermediate connections. For example, if I ping, I will get 12 or so successes then 4 or 5 failures, then repeats. Because of this, I cannot SSH into it to even start the docker in the tutorial. Neither can I stay connected to it via the browser. I can connect just fine to the Nano through Ethernet though.

So would be interested in getting this fixed, but due to being under the gun, I thought I could just run the course directly on the Nano with an attached monitor/keyboard/mouse. I cannot figure out how to to do this.

An alternate method might be running the cours by connecting to the Nano via Ethernet instead of USB?

I am assuming there is a hardware problem with connecting the nano via the USB to my laptop, so I am thinking these are my only choice. Any ideas?


Hi @gadworx, when you connect your monitor/keyboard/mouse and boot the Nano, does the desktop show up?

Yes, you could connect your Nano to your network router and SSH into it that way.

You may also want to try using a different USB port on your laptop, different micro-USB cable, or flash a fresh SD card for you Nano.

Hi Dusty!

Yes the desktop comes up and works as any desktop PC. I can also SSH into the Nano via the Ethernet but when running the commands to start the Docker, it does not work and returns this:

> dlinano@jetson-nano:~$ ./
> [sudo] password for dlinano:
> docker: Error response from daemon: OCI runtime create failed: container_linux.g o:345: starting container process caused “process_linux.go:430: container init c aused "process_linux.go:413: running prestart hook 0 caused \"error running h ook: exit status 1, stdout: , stderr: exec command: [/usr/bin/nvidia-container-c li --load-kmods configure --ldconfig=@/sbin/ldconfig.real --device=all --compute --compat32 --graphics --utility --video --display --pid=14383 /var/lib/docker/o verlay2/ff59c328435439b24bc62b9072605e261a646519e585e92229ac10f360dec9b7/merged] \\nnvidia-container-cli: mount error: file creation failed: /var/lib/docker/ov erlay2/ff59c328435439b24bc62b9072605e261a646519e585e92229ac10f360dec9b7/merged/u sr/lib/ file exists\\n\""”: unknown.
> dlinano@jetson-nano:~$

I am only guessing, but assuming it is expecting it to be run headless and is failing for some reason?

I can also connect to the Jupyter Server via the Ethernet, but the Course files are missing…as the did not execute correctly (I suspect).

This error is unrelated to the container being run headless - it typically means that the container you are trying to run was built against a different version of JetPack-L4T than the version of JetPack that you are running.

It looks like from this page, these are the container tags and the corresponding JetPack versions that they expect to be run on:

  • → JetPack 4.6
  • → JetPack 4.6.1

Note that if you are on JetPack 4.6.2, that can also run JetPack 4.6.1 containers.

1 Like

Awesome Dusty! You are getting me to the solution (if not already). When I check my JetPack version (at leat another article said to do it this way), I get:

$ apt-cache show nvidia-jetpack
Version: 4.3-b134

The link you provided seems to show DeepStream now requires 4.6.X. The image used was the one that was current recently and had v4.3 apparently. I had already tried the newest image (5.x), but it would not boot up the Nano so I reverted back to the image that did work. This is the issue I am sure. Because the 5.x image did not work. it led me to a make a post a couple of days ago : (Confused on my Nano model)

I am downloading “Jetson Nano Developer Kit SD Card Image, v4.6.1” now and will experiment with it and post my success I hope! :)

OK, yes - the JetPack 4.6.1 SD card image for Jetson Nano should allow you to run the container. The JetPack 5 SD card images are only for Jetson Xavier NX, those won’t work on Jetson Nano.

Good luck, hope that gets it working for you!

1 Like

Just wanted to update everyone and sing Dusty’s praises! The new SD image worked!

The problem arose from the Deepstream tutorial jumping me to the JetPack 5.x page (and me not being familiar enough with the model numbers). Since JetPack 5 did not boot with the Nano, I returned to the previous SD card that was made earlier this year, which was JetPack 4.3–which would not work with the DeepStream tutorial. The problem for newbies is that it is difficult just by looking at the Nano to determine its variation and difficult (for newbies) to discover what version of JetPack is installed…or even what JetPack even is! lol

So thank you so much Dusty for the education and then also pointing me to the solution!

OK great!, sorry for the confusion there with the SD card versions. Glad that you were able to get it working!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.