I am trying to flash the nvidia agx orin through docker and I am getting errors

Please provide the following info (tick the boxes after creating this topic):
Software Version
DRIVE OS 6.0.6

Target Operating System
Linux

Hardware Platform
DRIVE AGX Orin Developer Kit (940-63710-0010-300)
driveinstaller.log (103.9 KB)

SDK Manager Version
other

Host Machine Version
native Ubuntu Linux 20.04 Host installed with SDK Manager

Dear @nagireddy.raviteja,
I see e[01;31mCould not put Tegra-A in recoverye[0m in logs.
Does the board has any issue and you want to flash? Is tegra and aurix is accessible via serial console.

Can you put the board in recovery mode(run tegrarecovery x1 on and tegrarset x1 on aurix console) and check if you see any additional NVIDIA device in lsusb on host.

Can you give any guidelines or steps to put the board in recovery board.

Note: I wanted to flash the board for the installation of tensorrt. When I am flashing through sdk manager tensorrt is not getting installed.

Dear @nagireddy.raviteja,
TensorRT is part of DRIVE OS and will be installed when you flash the board. Please see /usr/src/tensorrt/ on target.

I see you have selected DRIVE OS 6.0.8.1 already(which is latest release). Does the board already has DRIVE OS 6.0.8.1?

Dear @SivaRamaKrishnaNV
The board has DRIVE OS 6.0.6. I checked /usr/src/ , no tensorrt found in the target board.

Dear @nagireddy.raviteja,
Thats strange. I see tensorrt folder in docker

root@6.0.6.0-0004-build-linux-sdk:/drive/drive-linux/filesystem/targetfs/usr/src# ls
ofa_kernel  tensorrt

Please check below instructions.

  1. Double check the connection instructions in Page -9 of DRIVE AGX Orin devkit Quick start guide
  2. Follow below instructions to confirm if the board is set into recovery mode. You need to two host terminals to run command
$sudo minicom -D /dev/ttyACM1 Run from host terminal-1 and the press enter to access the aurix console
$tegrarecovery x1 off  #Run on aurix console to set board in normal mode
$tegrareset x1 #Run on aurix console to reset the target
$lsusb #Run on host terminal -2. You should see one NVIDIA device
$tegrarecovery x1 on  #Run on aurix console to set board in recovery mode
$tegrareset x1 #Run on aurix console to reset the target
$lsusb  #Run on host terminal -2. You should see one an additional NVIDIA device.

Please share the connections pictures ands above commands logs for further guidance

we have a problem with flashing through docker, after successfully flashing the Bluetooth (no Bluetooth adapter found) and sound no longer works in AGX orin board, but when we flash through SDK manager Bluetooth and sound everything works but Tensorrt doesn’t get installed. If you can give a sollution where sound and Bluetooth work when we flash through docker, or why tensorrt is not getting installed through sdk manager it would be really helpful

IMP: (Flashed through SDK manager) from past one week the Bluetooth is not working in any machine. it connects and disconnects immediately, we tried everything removing bluez and re installing all even we fully flashed board but still same issue, any solution for that?

Dear @nagireddy.raviteja,
Please pull the docker container nvcr.io/drive/driveos-sdk/drive-agx-orin-linux-aarch64-sdk-build-x86:6.0.6.0-0004 to flash DRIVE OS 6.0.6. I think you flashed DRIVE OS 6.0.8.1 using docker. You can verify it with cat /etc/nvidia/version-ubuntu-rootfs.txt

Note that, bluetooth/wifi functionality is not officially supported and hence not verified.

okay @SivaRamaKrishnaNV we will try that docker version.

Now can you help with SDK Manager ? why tensorrt is not getting installed while flashing through SDK Manager , we even tried with GPU Host but still same problem why is that ? and what can we do ?

Dear @nagireddy.raviteja ,
Could you check on target sudo dpkg -l | grep TensorRT to confirm if TensorRT is installed? The TensorRT samples can be copied to target from host and compiled on target directly.
`

@SivaRamaKrishnaNV
i just checked that command which you gave nothing came , just an empty command.

Dear @nagireddy.raviteja,
Could you please check flashing with the DRIVE OS 6.0.6 docker and confirm if tensorrt is installed on target?

Yes @SivaRamaKrishnaNV with Docker we are getting , we are not getting with SDK Manager,

Does that mean, you have flashed 6.0.6 using docker and noticed tensorrt folder on target. Also, you confirmed the driveos version on target using cat /etc/nvidia/version-ubuntu-rootfs.txt ? Could you share the output for confirmation?

Dear @nagireddy.raviteja ,
Could you provide any update?