I can´t install NVIDIA GPU drivers on N-series VMs running Linux

Following this guide when I try to install cuda I receive below message:

The following packages have unmet dependencies:
cuda : Depends: cuda-11-7 (>= 11.7.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I have been searching for the root of the issue but I could not be able to solve it.
I am new with Linux and Azure VMs. Is there something who can help me to solve it? I’d be very grateful

That guide is bogus and ambigous, shouldn’t be used.
Which exact N-series VM do you have? What did you do so far (installing drivers, etc)?

Hi, generix.

Thanks for answering.

  • I am working with Standard NC6s v2.
  • I have tried to uninstall and reinstall NVIDIA drivers but nothings work for me.

When I execute nvidia-smi , I get this:
| NVIDIA-SMI 470.82.01 Driver Version: 470.82.01 CUDA Version: 11.4 |
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
| 0 Tesla P100-PCIE… On | 00000001:00:00.0 Off | 0 |
| N/A 33C P0 26W / 250W | 2MiB / 16280MiB | 0% Default |
| | | N/A |

| Processes: |
| GPU GI CI PID Type Process name GPU Memory |
| ID ID Usage |
| No running processes found |

Am I doing something wrong?
Could you guide me on how to set up my VM?

Thanks a lot for answering!

Hi, generix.

Thanks for answering!

A1. I am working with Standard NC6s v2.

A2. I have tried to install CUDA, CUDNN, and uninstall/reinstall NVIDIA drivers but I have not been able to set up the GPU yet.

When I execute nvidia-smi I get this response:

Generix, could you guide me on how to set up this VM and its GPU. I have been training a model with CPU since 12 hours ago and have not finished yet :(.

So you already have a 470 driver up and running, supporting cuda 11.4. Which distibution are you using, Ubuntu 20.04?
Which cuda repo did you add, the local deb file or the network deb?
Which cuda version do you need for your project?

A1. Yes, Ubuntu 20.04
A2. Local deb file (cuda-11-7_11.7.0-1_amd64.deb)
A3. I’m not sure about this question. Can you explain me a little more about it?

I guess you’re using packaged binaries (tensorflow,pytorch, etc.), depending on version those require a minimal cuda driver or specific runtime/cudnn version. So just throwing cuda 11.7 on your system won’t help you at all. Please check the exact requirements beforehand and tell how you installed the binaries. There might be easier ways to install all requirements e.g. through pip.