I can't debug CUDA with VC 2005

http://forums.nvidia.com/index.php?showtopic=30273

Recently I followed this article to add the cuda.rules…
and then I can’t stop the program at the breakpoint …
Before adding the rules , I didn’t change any VC enviroment parameters
and it could be interrupted…

what’s wrong with my VC 2005?
please~help me~~ :no:

You should set the link’s debug model on in the VC environment. And you can only debug in EmuDebug model.

hello~kyzhao
I have installed the “VS2005 Project Wizard for CUDA” you supported…
and I used it to create a new project…
But I still can not debug on EmuRelease or EmuDebug…

In VS environment , about the option “Custom Build Rules”
I can find 2 CUDA options :

  1. path : VCProjectDefaults\cuda.rules (kyzhao supported I think…)
  2. path : NVIDIA CUDA SDK\common\scripts\nvcc.rules
    (CUDA SDK supported)

(1)
when I enable cuda.rules to compile…
The VS couldn’t compile all instruction about CUDA
and couldn’t find the “cutil.h”…
:(

(2)when I enable cuda.rules to compile…
The VS “can” compile the cu file…but EmuRelease or EmuDebug is
still useless
:(

How can I set my VS 2005 environment parameters and
make it normal…

Please Help me…:wacko:

First select the Solution Configuration to EmuDebug.

Then right click on the project, select the properties.

Linker–>Debugging–>Generate Debug Info: Yes.

Then :w00t:

Thanks ~kyzhao
I enabled the VCProjectDefaults\cuda.rules to compile…
and followed the step you said…
But it still couldn’t stop the program at the break point…
I guess something wrong with my setting in VS 2005 before…

I didn’t use the visual assist…
so I can’t follow the step you said on your web…

Is visual assist a keypoint ?

My VS can’t work…how sad…:(

Realy?

EmuDebug–>Generate Debug Info: Yes. ? Press F10 can it work?

And the visual assist is not necessary! If you don’t have, forget about it.

hello ~ kyzhao
Thanks for your suggestion…
It could work Thanks :)