I can't find my Jetson tx2 device while i write lsusb command

I am trying to install jetpack 4.3 but i can’t flash the device. have tried to do so and it cant detect and nvidia jetson device connected to usb.

Are you using the supplied micro-B USB cable? Is the TX2 in recovery mode? If so, and it still doesn’t work, are you using a VM?

I have the same problem, I’m using micro-B USB adapter connected to USB C on my computer but can’t see any nvidia device using lsusb. Is it possible to work with USB c?

If the Jetson is in recovery mode, and the cable connected to the micro-OTG USB port of the Jetson is the supplied micro-B USB, then the adapter from type-A to type-C should not be a problem.

If, on your host you monitor “dmesg --follow” with that USB not connected, and then you put the Jetson in recovery mode, followed by then connecting the cable, then what do you see from dmesg during cable insert?

For me, changing the micro usb cable has worked. I had 3 micro usb cables and only one of them worked.

Most of the micro-B USB cables out in the consumer world are really only adequate for charging. Not many of them are actually of sufficient quality for reliable data transfer, and so the cable which comes with the dev kit is usually recommended. I am not surprised to hear you had one cable out of several which worked.

1 Like