I can't log in to the nucleus server from Isaac Sim

Please help.
When I try to sign in to the Nucleus server from Isaac Sim, I get the following error and cannot sign in:

2021-04-08 05:21:06 [68,704ms] [Warning] [omni.client.plugin] Tick: authentication: Could not connect to discovery service at “ws://localhost:3333”, attempting fallback authentication

Screenshot from 2021-04-08 14-20-55

I changed the default nuclear server settings in _build / linux-x86_64 / release / experience / isaac-sim.json, but it didn’t make sense.
Can anyone please tell me why I can’t connect to the Nucleus server?
Thanks you.


Could you try the new connection using the workstation IP XX.XX.XX.XX:3009 instead of using localhost:3009?

Try too. Can you also check if you can access the server on the browser at http://localhost:8080/login.

The warning is fine. It can we ignored.

Thank you for your reply.

I tried both [] and [localhost: 3009], but the problem was not resolved.
I can access the omniverse browser from http: // localhost: 8080 / login.

Screenshot from 2021-04-09 08-58-28

I wrote the IP address in the following place.
Is this correct?


"isaac": {
    "nucleus": {
        "default": "omniverse://"

Thanks you.


Did you try it?

I have the same problem using localhost and (red). However, I am running all using docker containers. That is why only the real workstation IP (where I have all the containers) works (green)

You can use the command ip a to know the IP of the workstation

I succeeded in that!
Now I can use the Nucleus server.

Thank you very much.

Hi where to find _build / linux-x86_64 / release / experience / isaac-sim.json in file manager or using terminal

Hi @sasikumarthechamp

This path is for Isaac Sim versions prior to 2021.1.0.

For new versions the experience files are located in the path ~/.local/share/ov/pkg/isaac_sim-2021.1.1/apps for local deployment or /isaac-sim/apps for containers

So, if you want to modify the default nucleus path you can edit line 249 of the omni.isaac.sim.base.kit file as shown in the documentation Setting default Nucleus Server

nucleus.default = "omniverse://localhost"