I can't seem to download Nvidia driver on my Linux Ubuntu

Hello,

I am currently using an ASUS laptop that has a NVIDIA rtx 4060 laptop as my GPU and I have a Ubuntu 20.04.6 LTS. I’m trying to install and run Nvidia driver on my laptop to run ROS. I tried to run nvidia driver 550 through additional drivers on software & updates but when I did it a black screen with blinking underscore showed up. I got back to the original login screen through purging the nvidia file through 'sudo apt-get purge ‘nvidia*’.

But I think I did something wrong with the commands which resulted with no additional drivers showing up in my additional drivers interface anymore. When I check my settings it shows:

Processor = MD® Ryzen 9 7940hs w/ radeon 780m graphics × 16
Graphics = llvmpipe (LLVM 14.0.6, 256 bits)
Gnome Version = 3.36.8

When I run nvidia-smi it shows:
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

For your amd gpu, you will need a recent kernel and firmware
kernel: https://github.com/zabbly/linux#installation
firmware: http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_20220329.git681281e4-0ubuntu3.29_all.deb

Afterwards, please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Your CPU from 2023.
Yout kernel - Ubuntu 20.04.6 LTS - 4 years old, your processor did not exist when this kernel released.
And in case of “laptop” - it not clean if your monitor connected to integrated amd or nvidia.
If monitor connected to amd-integrated - then you need working amdgpu drivers that only in latest kernel for your 2023 cpu.

It worked thank you!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.