I can't set the breakpoint in kernal under EmuDebug mode

I am a rookie in cuda programming and develop the cuda program under the EmuDebug mode.

When I set

the breakpoint in kernel doesn’t work, but if I change to

the breakpoint works!

I don’t know what’s the problem. Are there any hardware limitations in the EmuDebug mode (I have no cuda CPU in my development environment)

Thanks very very much

You can’t launch 3D grids.

Doesn’t dimBlock mean the dimension of threads in one block?

I set “BLOCK_SIZE” to 16. When I set dimBlock(BLOCK_SIZE, BLOCK_SIZE, 2), the breakpoint in kernel does work. But if I set dimBlock(BLOCK_SIZE, BLOCK_SIZE, 4) or something > 4, the breakpoint in kernel doesn’t work.

My development environment has no CUDA enabled GPU. I don’t know what the problem is ?

Thanks very very much…

Can’t have more than 512 threads in a block, either.