I could not handle the "ERROR: ld.so: object '/libgtk3-nocsd.so.0' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored."

Hello,

I am currently working on the jetson nano on tasks: object detection and pose estimation. For this , I have installed the all necessary libraries, like tensorflow, pytorch, jupyter lab etc… Ater installing the torch, I could not run the any python script which is dependent on “pytorch” and the terminal left me this error…(ERROR: ld.so: object ‘/libgtk3-nocsd.so.0’ from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.)… I have tried so many solutions like editing the bashrc file and installing or removing the gtk3-nocsd, even I tried gtk3-nocsd:i368 installation, to this I got “can not locate the package” issue…

and I could not load the pytorch on jupyter lab… this is the error I see on output console…[OSError: /usr/local/lib/python3.6/dist-packages/torch/lib/libgomp-d22c30c5.so.1: cannot allocate memory in static TLS block]

I have tried all available solutions on stackoverflow and nvidia forum… no way, whatever I try, It puts me into more trouble… I have no clue why I can not get rid of that PRELOADED error… It just stops everything , that is ran in terminal on jetson nano…

I really appreciate your help and effort…I have been struggling to solve these issues for past few weeks…

I am happy to provide more info…

Thank you
Konka Yamini

Hi,

Please noted that gtk3-nocsd:i368 is a desktop package but Jetson is an ARM system.
You should install it with the following command:

sudo apt install gtk3-nocsd

The LD_PRELOAD error indicates the system try to find a library but it doesn’t exist.
Would you mind cleaning up the LD_PRELOAD variable and try it again?

For example:

$ echo ${LD_PRELOAD}
$ export LD_PRELOAD=""
$ echo ${LD_PRELOAD}

Thanks.

Hello AastaLLL,

Thanks for your quick reply. Yes finally I resolved it. The mistake I had done was, in the path, I used x86-64 system instead of aarch64, This copied somewhere from web and I did not recognize it. Now everything runs well… I am able to run my algo on jetson nano…

Best wishes

Good to know this!

Thanks for the update.