I have cuda setup problem ... pls help me

nvcc -V nvcc: NVIDIA (R) Cuda compiler driver Copyright (c) 2005-2015 NVIDIA Corporation Built on Mon_Feb_16_22:59:02_CST_2015 Cuda compilation tools, release 7.0, V7.0.27 nvidia-settings -q NvidiaDriverVersion

Attribute ‘NvidiaDriverVersion’ (ram-HP-ENVY-15-Notebook-PC:0.0): 346.82
Attribute ‘NvidiaDriverVersion’ (ram-HP-ENVY-15-Notebook-PC:0[gpu:0]):
346.82

lspci -v | grep -i nvidia0a:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 850M] (rev a2) Kernel driver in use: nvidia ram@ram-HP-ENVY-15-Notebook-PC:~/ramki/NVIDIA_CUDA-7.5_Samples/1_Utilities/deviceQuery ^C
ram@ram-HP-ENVY-15-Notebook-PC:~/ramki/NVIDIA_CUDA-7.5_Samples/1_Utilities/deviceQuery$ nvidia-settings -q NvidiaDriverVersion

Attribute ‘NvidiaDriverVersion’ (ram-HP-ENVY-15-Notebook-PC:0.0): 346.82
Attribute ‘NvidiaDriverVersion’ (ram-HP-ENVY-15-Notebook-PC:0[gpu:0]): 346.82

uname -r 3.16.0-49-generic ./deviceQuery
./deviceQuery Starting…

CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 35
-> CUDA driver version is insufficient for CUDA runtime version
Result = FAIL
cat /proc/driver/nvidia/version NVRM version: NVIDIA UNIX x86_64 Kernel Module 346.82 Wed Jun 17 10:37:46 PDT 2015 GCC version: gcc version 4.8.4 (Ubuntu 4.8.4-2ubuntu1~14.04) lsmod | grep -i nvidia
nvidia 8379764 35
drm 311018 6 i915,drm_kms_helper,nvidia
$ nvcc -V
nvcc: NVIDIA ® Cuda compiler driver
Copyright © 2005-2015 NVIDIA Corporation
Built on Mon_Feb_16_22:59:02_CST_2015
Cuda compilation tools, release 7.0, V7.0.27

$ nvidia-smi
Thu Sep 17 04:06:23 2015
±-----------------------------------------------------+
| NVIDIA-SMI 346.82 Driver Version: 346.82 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce GTX 850M Off | 0000:0A:00.0 N/A | N/A |
| N/A 58C P0 N/A / N/A | 298MiB / 4095MiB | N/A Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Processes: GPU Memory |
| GPU PID Type Process name Usage |
|=============================================================================|
| 0 C+G Not Supported |
±----------------------------------------------------------------------------+

You have a corrupted or incomplete driver install.

I suggest you review this thread:

https://devtalk.nvidia.com/default/topic/876432/cuda-setup-and-installation/no-cuda-capable-device-is-detected/

In a nutshell, start over with a reinstall of the OS, and follow the instructions in the linux getting started guide exactly.