I have some err when i try to change logo

I tried it according to the official method.

  1. Generate bmp.blob
  2. Put in the bootloader
  3. Use sudo ./flash.sh -r -k BMP jetson-nano-emmc mmcblk1p1
    But I have the following problem. At first it said I don’t have system.img, I tried to copy the img file from my jetson. Then the following problem occurs:

Hi,

In the first command when the flash.sh told you cannot find system.img… remove the “-r” in your command.

“-r” means re-use the pre-existing system.img. But obviously this is your first time flashing your board so there is no system.img.

Thinks for your help.
i removed -r and used “sudo ./flash.sh -k BMP --image bootloader/bmp.blob jetson -nano-emmc mmcblk1p1”.but i have the err is “keyfile ……………………not found”. could you please help me?

if you don’t add “–image bootloader/bmp.blob”, what would it tell?

Also, are you sure you didn’t modify anything else? This error seems not common. We don’t use any “mage” file there. I feel it is a typo of “Image”, but not sure where it came from.


thinks.
hi, this is the err if i remove the "-- image b…………“.

Are you using a VM as your host machine?

yes i using vm

VM may not support well in flash. Please try to use native ubuntu host or at least a dual boot machine first.

ok, thinks for your help!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.