I installed deepstream 6.3 environment, when I run the program, why does it load the dependencies of deepstream 6.1?

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
• DeepStream Version
• JetPack Version (valid for Jetson only)
• TensorRT Version
• NVIDIA GPU Driver Version (valid for GPU only)
• Issue Type( questions, new requirements, bugs)
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

The original environment of my machine was deepsteam6.1.1, and then I uninstalled it by running sudo ./uninstall.sh according to the official tutorial, and deleted cuda and tensorRT, etc., and then reinstalled the deepstream6.3 environment according to the documentation, but why did I run the program it will still load deepstream6.1? Why is my tensorRT version 8.4? Logically speaking, it is 8.5

root@box:/home# deepstream-app --version-all
deepstream-app version 6.3.0
DeepStreamSDK 6.3.0
CUDA Driver Version: 12.2
CUDA Runtime Version: 12.1
TensorRT Version: 8.4
cuDNN Version: 8.4
libNVWarp360 Version: 2.0.1d3

root@box:/home# python3 support_multi_rtsp.py
Traceback (most recent call last):
File “support_multi_rtsp.py”, line 5, in
import pyds
ImportError: /opt/nvidia/deepstream/deepstream-6.1/lib/libnvds_meta.so: cannot open shared object file: No such file or directory
My original environment is deepstream6.1.1,the steps to uninstall the environment are as follows:

1.Uninstall deepstream(https://docs.nvidia.com/metropolis/deepstream/6.1.1/dev-guide/text/DS_Quickstart.html#dgpu-setup-for-ubuntu)

2.Uninstall cuda:
sudo apt-get --purge remove "*cuda*" "*cublas*" "*cufft*" "*cufile*" "*curand*" \
 "*cusolver*" "*cusparse*" "*gds-tools*" "*npp*" "*nvjpeg*" "nsight*" "*nvvm*"

3.Uninstall driver:
./NVIDIA-Linux-x86_64-xxx.run --uninstall 


a.sudo apt-get --purge remove "*nvidia*" "libxnvctrl*"

b.sudo apt-get autoremove

c.find / -name "*nvidia*",Manually delete the driver that does not match the query result using rm -rf

4.Uninstall tensorRT:
sudo apt-get --purge remove libnvinfer8=8.4.1-1+cuda11.6 libnvinfer-plugin8=8.4.1-1+cuda11.6 libnvparsers8=8.4.1-1+cuda11.6 \
  libnvonnxparsers8=8.4.1-1+cuda11.6 libnvinfer-bin=8.4.1-1+cuda11.6 libnvinfer-dev=8.4.1-1+cuda11.6 \
  libnvinfer-plugin-dev=8.4.1-1+cuda11.6 libnvparsers-dev=8.4.1-1+cuda11.6 libnvonnxparsers-dev=8.4.1-1+cuda11.6 \
  libnvinfer-samples=8.4.1-1+cuda11.6 libcudnn8= libcudnn8-dev= \
  python3-libnvinfer=8.4.1-1+cuda11.6 python3-libnvinfer-dev=8.4.1-1+cuda11.6
  1. If you run native deepstream-app, can it work normally ?

  2. try which deepstream-app to find path of deepstream-app then run ldd deepstream. what the output ?

3.try install.sh in /opt/nvidia/deepstream/deepstream

  1. user_deepstream_python_apps_install.sh reinstall python bindings.

  2. It is recommended to use docker, which is a simple and convenient method

Hi, I met you again, my old friend. You are really amazing. Thank you for your suggestion. I have redone Python binding to solve the problem. By the way, do you know why my TensorRT version is not 8.5?

ls -l /usr/lib/x86_64-linux-gnu/libnvinfer.so

Does this library exist? Is its soft link to version 8.4?
Maybe you can try docker

Yes, it exists. Docker is excellent, but this is a development environment

/usr/lib/x86_64-linux-gnu/libnvinfer.so → libnvinfer.so.8.5.3

If you execuse install.sh in /opt/nvidia/deepstream/deepstream to flush cache

Or reboot ?

Are there any changes?

I’m not quite sure why this is the case

I’m sorry, it still doesn’t work.Anyway, thank you for your help

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.