I met a keyboard problem, some keys was wrong:

like delete, backspace, left right, etc.
how can i restore keyboard default?
i tried by:
nono /etc/default/keyboard,
and reboot, but failed many times same as wrong.

thank you

Did you try to use the ubuntu system setting to change the keyboard layout?

how to change that?

Can you open the keyboard setting as this one and check the “text Entry”?

it seems is ok and it is USA input from keyboard.

Please click the keyboard here and then test if those keys are responding as expected.


i tried all keys are matched well now.
but when i input a long comand,
like deepstream-test5-app -c rtsp:// xxxxxx, sth etc,
long command it will be input wrong for delete, backspace, blank, these keys are wrong will be.

when reboot it shows i2c was wrong with keyboard probe function.

Honestly, I cannot understand what error you are talking about

  1. For long command, maybe you can share a video to demo the error.

  2. For the reboot issue, I am not sure why a “i2c” error would happen because I think your keyboard should be a usb interface. Thus, share us the log if possible. And tell us how it affects your keyboard.

pls ignore the problem as if it does not affect the work seems.

thank you for your time.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.