I tried using splitmuxsink to save. deepstream-app blocks directly if there is an offline RTSP source

Please provide complete information as applicable to your setup.

Hardware Platform: Jetson Xavier Nx
DeepStream Version: DeepStream-6.1
JetPack Version (valid for Jetson only) : 5.0.2 GA
TensorRT Version:
Issue Type( questions, new requirements, bugs) :
I tried using splitmuxsink to save the file. If there is one or more offline RTSP sources, the process will block a few seconds after I try to start deepstream-app.
This doesn’t happen when I use filesink.
How should I modify it.

Which deepstream demo did you run and how to use offline RTSP sources? If we can repro the problem in our env, We can analyze quickly.
The pipeline you posted cannot be seen clearly after being enlarged.

1.I run deepstream-app and I replaced mux and filesink with splitmuxsink.
2.I used 4 rtsp sources in config, and I turned off one or more of them to power down the camera that are not connected to the Internet. Then start deepstream-app and the process will block.
3.The deepstream-app will reconnect to the rtsp source that are not connected to the Internet. After a few reconnections, it will block.

IMG_1891.zip (4.3 MB)
I compressed and uploaded pipeline png.

Could you share your deepstream-app config file? You can help to narrow down the scope.

  1. Will it block if use file sink or fake sink?
  2. You can use gdb to check where the code hangs first.

1.file sink and fake sink do not happen like this, but splitmuxsink does.

Sorry, I’m not using the configuration file anymore because I’m using both Tiling and streamdemux. You can check the pipeline diagram I provided.

There is no update from you for a period, assuming this is not an issue anymore. Hence we are closing this topic. If need further support, please open a new one. Thanks

OK. Could you attach your minimized demo code to us? Will it block if you use 1 or 2 source?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.