I updated Nvidia driver I shouldn't have

[url]I just installed Ubuntu 12.04.3 LTS on a Windows XP Media Center Edition 2005 Compaq Presario. It went well and everything worked. Then it told me there was a new video card driver available so I clicked to download and install. Later web research on another computer informed me it wasn’t supported. Can I fix this?
Here’s pictures of the screen on restart. Sorry for the poor quality if better one’s will help I’ll try taking more.

Here’s the first screen on restart.

After a few seconds I get a flashing dash in the upper left corner for 30 seconds or so. Then I get this screen

Seams to load okay then then this screen.

A few seconds later I get this.

The - blinks and no keys do anything. Pressing the off switch finishes the page with this and it shuts down.

Is there any hope or just e-waste? If there is please try to not make your response to technical.

Thanks for any help! Lonnie

When you get to the endless blinking dash, can you do a Ctrl-Alt-F1 and get a console login session to appear?

No, nothing happens.

I’m 99% sure NVIDIA drivers didn’t cause this.

As a solution - boot in single mode (append 1 to kernel params) and remove the drivers.

Okay you gota tell me how to do that. I’m clueless!

Edit to add: I chose the option to totally replace the windows operating system when installing Ubuntu.
Please excuse my ignorance as I’ve only been using Linux 3 days and chose Ubuntu as it is recommended to be the easiest. Is this driver stuff on the hard drive? Is there a way to erase it and just install Ubuntu again? I have no thing on there to lose. It seams the bios is the only thing I can get into but I don’t know what to do there.

the problem is for Networkmanager/modemmanager

see the last screenshot

Is this directed to me? It’s just a home network, D-link router, wireless network card plugged into said computer. Worked okay after Ubuntu install and downloaded driver update okay. I’m on that network now on a different computer.

The last screenshot is just the network manager coming down in response to the power off button being pressed and is normal.

Since it’s really hard to know what the problem is, and you don’t care so much about the installation since it’s new, I would recommend just getting your Ubuntu install media (CD or USB key or whatever you used) and re-installing Ubuntu right over the existing installation. Just wipe it like you did XP.

There is a way to recover it, but troubleshooting remotely over a forum is going to be a lot harder than just starting over.

I tried that earlier but it read the disc for about 30 seconds then quit. I just tried again inserting while bios was first starting and this time it worked! Thank you so much. And thanks to everyone for your responses!

Didn’t work. The disc loaded (download manager I think) then instead of the hour and twenty minute download starting it said installation complete and ejected the disc and went to this screen.

Well 15 hours later I finally got it. I inserted Windows XP Pro installation disc which gave me the option to delete the partition where the system info was stored then removed it and installed Ubuntu again. Thanks again for your time.

Lonnie