I want to install magenta on jetson nano

Hello.
For the first time through jetson nano, I am going to study deep learning in the art of music and painting called magenta.

The problem is trying to install the jetpack type from the past, but it is frequently stuck and freezes.

I was wondering if I should ask google if I should ask nvidia.
Have you ever installed google magenta?

Please let me know if there is a way.
If not, please let me know.

I hope you always have a good day.

Hi,

Sorry that we don’t have too much experience on magenta.

But would you mind to tell us why you need to install the previous JetPack?
The latest software should able to give you a better performance.
Is this related to the dependency of magenta?

Thanks.

Hello.

It is not necessary to install jetpack.

Even if I installed python3 and tensorflow required for magenta on jetson nano Ubuntu 18.04, magenta could not be installed.

So I tried it through jetpack, but it also failed.

Still, the most installation was done through jetpack except that tensorflow_addons was not found.

I would like to ask if you can recommend another method.

I am a beginner deep learning user. I have tried various methods on Google, but they didn’t work.

Can you tell me what additional information is needed?

Thank you. I wish you a nice day.

Hi,

May I know how do you install the TensorFlow package?
Do you follow our tutorial here?
https://docs.nvidia.com/deeplearning/frameworks/install-tf-jetson-platform/index.html

Thanks.

Hello.
I followed the method as you said.

I installed jetpack and proceeded with tensorflow as written.

Even with the method you mentioned, the phenomenon of stopping that tensorflow_addons is missing when installing magenta is repeating.

Hi,

There is no tensorrflow-addons prebuilt package for Jetson device.
Please build it from source with the instruction shared here:

Thanks.

Hi

Um… I got a “bazel” problem. Only version 0.2.6 can be installed, and it will not work properly if it is installed beyond that. It requires 1.0.0 or higher, but there was a problem installing it normally.

/home/bb110/bin/bazel: line 89: /home/bb110/.bazel/bin/bazel-real: cannot execute binary file: Exec format error
/home/bb110/bin/bazel: line 89: /home/bb110/.bazel/bin/bazel-real: Success

Thanks.

Hi,

cannot execute binary file: Exec format error

The exec format error indicates that the architecture of binary is incorrect.
This indicates the tool is built for a desktop user rather than Jetson, which is ARM 64-bit system.

Thanks.