I would like to control PWM0( LCD_BL ) on L4T 24.2.1

I would like to control PWM0( LCD_BL ) on L4T 24.2.1 Jetson Tx1 reference board.

i did try under link. but can not contorl pwm0.
https://devtalk.nvidia.com/default/topic/988669/?comment=5060881

i want detail guide plz

Hi walterkim
How do you verify the control not working. Did you probe the signal?
Below is my probe result.

cd /sys/class/pwm/pwmchip0

echo 0 > export

cd pwm0

echo 20000 > period (20us is the total time period of the pulse)

echo 10000 > duty_cycle (50% duty cycle)

echo 1 > enable

Could you send dts file and kernel config files?

i used jetson tx1 reference board

did you use jetson tx1?

i did try Pin number B27, Pin name LCD0_BKLT_PWM. is it right?

I did use jeston tx1 withd r24.2.1 without any change.
The Pin number is correct.

Check Plz?

IMG_7270.JPG

Your measure is correct. Did you probe any thing?

I installed JetPack-L4T-2.3.1-linux-x64.run to jetson tx1 reference board.
um…

no signal…

change jetson tx1 module and retry then same result no signal.

i cannot find differet.

my carrier board is bad???

I can’t tell what happen on your board. What the result to cat /sys/kernel/debug/pwm
Below is my result.

platform/7000a000.pwm, 4 PWM devices
 pwm-0   (sysfs               ): requested
 pwm-1   (pwm-regulator       ): requested enabled
 pwm-2   ((null)              ):
 pwm-3   (pwm-fan.43          ): requested enabled

cat /sys/kernel/debug/pwm
platform/7000a000.pwm, 4 PWM devices
pwm-0 (sysfs ): requested enabled
pwm-1 (pwm-regulator ): requested enabled
pwm-2 ((null) ):
pwm-3 (pwm-fan.43 ): requested enabled
root@tegra-ubuntu:/sys/class/pwm/pwmchip0/pwm0#

Hi walterkim,

As for LCD_BL_PWM routing, no other devices on it except 2 connectors, J23 & J13, so it is hard to be damaged. Did you try probe pin head instead of foot? And you can remove module, simultaneously probe pin B27 of J13 and pin 10 of J23 to check the connection.