I2C issue on Jetson Nano

Hi ,

I have connected MLX90640 IR sensor to i2c1 bus of Jetson nano. But its not getting detected most of the times. The detection ratio is like 1 out of 20 times. I have probed the i2c lines while using “i2cdetect -y -r 1” command to detect the MLX90640 device on i2c bus, but i found that SCL is pulling low & not releasing at all.

image

Next when i try to connect any device to i2c0 bus, i found the board doesnt boots up at all. @ShaneCCC @snarky

Thanks

Hi,

May i get any updates on the above issues.
@ShaneCCC @snarky

Thanks

Hi,

Does the board recovery to work after you remove the i2c device?
The I2C0 and I2C1 have 2.2kohm pull-up to 3.3v on module.
I2C2 have 2.2kohm pull up to 1.8v on module.
Would you please figure your connections? Please make sure the correct signal are used.

Hi edli1983,

Thanks for the reply!!

Yes, the board does recovers to work once we remove the i2c device.
I have connected the device in i2c1 & also in i2c0 since we need 3.3 v. The device detects on i2c1(detection ratio: 1/15 attempts) where as on i2c0 the board doesnt even boot mostly, if we connect any i2c device.

To make sure the same MLX90640 device is being detected on other platforms like beaglebone.

Hi

Would you let us know how you connect the i2c device? how about SCL status on both side if you just disconnect SCL, are you supply the correct power the MLX90640?
Is there uart log output when you connect device on i2c0 bus ?

Hey edli1983,

We just resolved the issue. There was some issue with ground pin connection. Now its detecting the MLX90640 sensor in each reboot.

Thanks a lot for the support !!!

Thanks for let’s know your result.

Hey @surya.narayan i am also facing problem with i2c with mlx90614. Can u please tell how did you resolve your issue

Hi jaditya8889,

In my case the problem was with ground pin connection of MLX90640 device. It wasn’t proper. Can you connect your IR sensor to any other board for e.g beaglebone & check whether its getting detected there or not .

Actually I solved it. Thanks for your reply. I2cdetect was not throwing up anything using this command i2cdetect-r-y 1 but when I tried to read a byte at 0x5A it read successfully. Then I just ran my code for the mlx90614 sensor and it worked flawlessly. I2cdump was also working. Don’t know what’s the problem with i2cdetect.