I2cdetect problem, thermometer python jetson nano, pip3

I have a few questions.

Now, first of all, I started using and learning jetson nano. I had a problem during the installation phase. Spidev files are supposed to exist but do not exist. I tried to install with pip3 by applying the solutions I found, but it is still not available and I get a different result in i2c detect. I followed the steps on this site Initial Setup | CircuitPython Libraries on Linux and the NVIDIA Jetson Nano | Adafruit Learning System.

I can’t continue my project.

-desktop:~$ sudo i2cdetect -y 1

[sudo] password for **:

Warning: Can’t use SMBus Quick Write command, will skip some addresses

0 1 2 3 4 5 6 7 8 9 a b c d e f

00:

10:

20:

30: – – – – – – – –

40:

50: – – – – – – – – – – – – – – – –

60:

70:

I am getting errors in my python codes. I keep getting errors even though the library is available. I’m using Spyder and it’s telling me to install ipykernel and cloudpickle. I installed it and when I do pip3 list I can see it but it still doesn’t work. What should I do?

I want to measure instantaneous temperature values ​​in a simple way using MLX90614. Can anyone give code as an example?

Thank you from now.

You can use i2c utils like i2cget to verify the HW first.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.