I2S TDM Mode on Xavier NX

Hi, is there a straightforward way to switch the I2S audio mode of the Xavier NX to TDM (‘dsp_a’ frame format)?

I have set up the pinmux using the Jetson-IO tool, but the channels are mangled up when I record. The device ID is: ‘jetsonxaviernxa,0’

I have had this working on the Jetson Nano by recompiling the device tree, but am hoping there’s a more straightforward way…

Thanks,

Ben

I managed to get this working by modifying the amixer settings as follows:

$ alsactl init jetsonxaviernxa 
$ amixer -c jetsonxaviernxa sset 'ADMAIF1 Mux' I2S5
$ amixer -c jetsonxaviernxa sset 'I2S5 codec frame mode' dsp-a

All working fine now.