Ibdump with connect-5: Failed to set port sniffer1: command interface bad param

We are using centos7 and Mellanox ConnectX-5.

We are trying to use ibdump from ibdump-6.0.0-1.50100.0.x86_64.rpm

This is the log…

ibdump

Initiating resources …

searching for IB devices in host

Port active_mtu=1024

MR was registered with addr=0x1648010, lkey=0xafc0, rkey=0xafc0, flags=0x1


Device : “mlx5_0”

Physical port : 1

Link layer : Ethernet

Dump file : sniffer.pcap

Sniffer WQEs (max burst size) : 4096


Failed to set port sniffer1: command interface bad param

ethtool from mlnx-ethtool-5.4-1.50100.0.x86_64.rpm

I then obtained ethtool from mellanox site and

tried to run this command

ethtool --set-priv-flags enp130s0f0 sniffer on

I get

ethtool: bad command line argument(s)

For more information run ethtool -h

How do I run ibdump with connectx-5 successfully?

Thanks

Hello Sainath,

Thank you for posting your inquiry to the Mellanox Community.

We see that your organization currently has a valid support contract with Mellanox.

As such, we’ve opened a Mellanox support ticket on your behalf.

We will continue to track this issue via our support portal, and will provide further information to you directly.

Thank you,

Mellanox Technical Support

HI Sainath,

Have you sloved this problem?​ I have the same problem with you. That is “Failed to set port sniffer1: command interface bad param”, i don’t know how to deal with it. If you know the answer, please share with me. Thank you a lot.😁

Hello Sainath,

I have the same problem with you

Initiating resources …

searching for IB devices in host

Port active_mtu=1024

MR was registered with addr=0x22ca650, lkey=0x862f, rkey=0x862f, flags=0x1


Device : “mlx5_1”

Physical port : 1

Link layer : Ethernet

Dump file : sniffer.pcap

Sniffer WQEs (max burst size) : 4096


Failed to set port sniffer1: command interface bad param

i don’t know how to solve it.if you solve this problem,please share the answer with me,thank you