I'd like to turn off the tx.

I want to turn tx off by replacing qsfp28’s tx_disable with 1.

Is there a possible way?


[root@SNIPER ~]# mlxcables -d mt4119_pciconf0_cable_0 --read_reg TX_disable

TX_disable = 0x00

[root@SNIPER ~]# ethtool -i eth2

driver: mlx5_core

version: 4.7-1.0.0

firmware-version: 16.26.1040 (MT_0000000010)


bus-info: 0000:3b:00.0

supports-statistics: yes

supports-test: yes

supports-eeprom-access: no

supports-register-dump: no

supports-priv-flags: yes

root@SNIPER ~]# ethtool -m eth2

Identifier : 0x11 (QSFP28)

Extended identifier : 0xcc

Extended identifier description : 3.5W max. Power consumption

Extended identifier description : CDR present in TX, CDR present in RX

Extended identifier description : High Power Class (> 3.5 W) not enabled

Connector : 0x07 (LC)

Transceiver codes : 0x80 0x00 0x00 0x00 0x00 0x00 0x00 0x00

Transceiver type : 100G Ethernet: 100G Base-LR4

Encoding : 0x05 (64B/66B)

BR, Nominal : 25500Mbps

Rate identifier : 0x00

Length (SMF,km) : 10km

Length (OM3 50um) : 0m

Length (OM2 50um) : 0m

Length (OM1 62.5um) : 0m

Length (Copper or Active cable) : 0m

Transmitter technology : 0x40 (1310 nm DFB)

Laser wavelength : 1302.350nm

Laser wavelength tolerance : 1.030nm

Vendor name : FS

Vendor OUI : 00:02:c9

Vendor PN : QSFP28-LR4-100G

Hi ,

  • Are you using Mellanox cable ?
  • Can you provide the output of mlxlink ?

mlxlink -d <device_id> -emc

Note - to get the device id run “mst start” and “mst status”

  • Did you try to set the TX_disable = 0x01 ?