IDE for CUDA Using Netbeans C/C++ IDE with CUDA

I am not sure, if this has anything to do with your error, but comparing your error message, with the ones above, I realized that in the nvcc call the option --link is not present. Are you sure you added it to the project configuration? It is shown in the picture of this link, which was posted by papag62…st&id=10747


I have included --link, but the errors still there. What could I do now?

nvcc --link -o dist/Default/nvcc-Linux-x86/matrixmul_1 build/Default/nvcc-Linux-x86/_ext/home/liliana/NVIDIA_CUDA_SDK/projects/matrixMul/matrixMul_1/../matrixMul_gold.o build/Default/nvcc-Linux-x86/_ext/home/liliana/NVIDIA_CUDA_SDK/projects/matrixMul/matrixMul_1/../matrixMul.o build/Default/nvcc-Linux-x86/_ext/home/liliana/NVIDIA_CUDA_SDK/projects/matrixMul/matrixMul_1/../matrixMul_kernel.o -L/usr/local/cuda/lib -lcutil -lcudart -lcublas -lcufft 

g++: build/Default/nvcc-Linux-x86/_ext/home/liliana/NVIDIA_CUDA_SDK/projects/matrixMul/matrixMul_1/../matrixMul.o: No such file or directory

g++: build/Default/nvcc-Linux-x86/_ext/home/liliana/NVIDIA_CUDA_SDK/projects/matrixMul/matrixMul_1/../matrixMul_kernel.o: No such file or directory

make[2]: *** [dist/Default/nvcc-Linux-x86/matrixmul_1] Error 255

make[2]: Leaving directory `/home/liliana/NVIDIA_CUDA_SDK/projects/matrixMul/matrixMul_1'

make[1]: *** [.build-conf] Error 2

make[1]: Leaving directory `/home/liliana/NVIDIA_CUDA_SDK/projects/matrixMul/matrixMul_1'

make: *** [.build-impl] Error 2

Build failed. Exit value 2.

Thank you.

Hi all!
I am new to CUDA and kinda new to C (I know some basics) - I read through the programming guide and I just wanted to get started with a simple “Hello World” and tried to set up Netbeans 3.5 (MS Visual Studio 2008 Express decided to hang each and every time I even started a project). I am running Windows Vista (Business) on a Dual Core with a 8600 on a laptop.
I have installed the drivers (CUDA demo programs do work), the SDK and the Toolkit. But now I am lost in setting up Netbeans to compile a simple .cu-file. Could someone walk me quickly through this in short steps?
Do I need to install GCC or some other c-compiler for the c+±support or does nvcc handle this? I could not find a make command (which comes, as I guess with a compiler like gcc) to tell Netbeans the path.
If Netbeans does not offer full support yet I would go for command line (am familiar with command line).
Would be grateful for some pointers to get me started.


ps.: Sorry for the English, it is not my native.

Can u plx tell me how to set up vim editor for use in netbeans 6.5. I am currently using it for CUDA but I dont want to discard my fav vim too.


I am using Netbeans 6.5 for CUDA but Netbeans keeps giving me errors for functions with device or global variable names. Are you facing the same problems and ignoring it ?


I’ve tried to use your insturctions , but encountered some problems. I have found only
/home/blackswan/NVIDIA_GPU_Computing_SDK/C/lib/libcutil.a and /usr/local/cuda/lib/ libraries, but no libcudart.a.libcuda.a. CUDA installed correctly, I’ve cheked some examples from SDK.
now I have an error
nvcc fatal : Unknown option ‘f’
where is this keyand how can I remove it?

Kubuntu 9.04, NetBeans 6.7.1, CUDA 2.3,

I know it’s too late but if this goes to help someone here is an answer to your problem that helped me a lot.