If I purchased 7.2, can I install 7.0??

Hi All,

Last year I purchased 7.2 of the Fortran Workstation, however I need 7.0-7 for the programme I am trying to compile (They state that this is the compiler version to use)

I have downloaded 7.0-7 and tried to install using the FLEXlm licence manager on SUSE 10.3.

When I generated the licence.dat it said for 7.2 and older, so I assumed all would be ok however I am getting the error;

pgf77 7.0-7 32-bit target on x86 Linux
Copyright 1989-2000, The Portland Group, Inc. All Rights Reserved.
Copyright 2000-2007, STMicroelectronics, Inc. All Rights Reserved.
pgf77-linux86: LICENSE MANAGER PROBLEM: Failed to checkout license
pgf77-linux86: LICENSE MANAGER PROBLEM: Failed to checkout license
pgf77-linux86: LICENSE MANAGER PROBLEM: Failed to checkout license
pgf77-linux86: LICENSE MANAGER PROBLEM: Failed to checkout license
pgf77-linux86: LICENSE MANAGER PROBLEM: License server system does not support t his feature.
Feature: pgf77-linux86
License path: /opt/pgi/license.dat
FLEXnet Licensing error:-18,147
For further information, refer to the FLEXnet Licensing End User Guide,
available at “www.macrovision.com


Your advice would be greatly appreciated!

Many thanks

Sorry to bother again!

Got it working by updating the pgroupd daemon…

Cheers,

Hi Dwild,

As you found out, you can use all release up until 7.2 with a 7.2 license. However, due to some new license features added to our 7.2 compilers, you need use the latest license deamons (lmgrd and pgroupd).

  • Mat